#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?i)(\d+[.,]?\d+)\s*(?:-.*\bfurnished\s*)?(p/?w|wdk|per week|weekly|/w|p\\.?c\\.?m|mth|pm|per month|per night|pn|p.a)?"
Local $sString = "$350.00" & @CRLF & _
"$450.00 pw" & @CRLF & _
"$320 - fully furnished pw" & @CRLF & _
"$325 per week" & @CRLF & _
"$495pw - Views! White goods!" & @CRLF & _
"$460p/w + gst and outgoings" & @CRLF & _
"$300 wdk" & @CRLF & _
"$390pw / $1695pcm" & @CRLF & _
"$180 pw / $782 pm" & @CRLF & _
"$375 Per Week/Fully Furnished" & @CRLF & _
"$350 pw + GST & Outgoings" & @CRLF & _
"APPLY NOW - From $270 per week" & @CRLF & _
"$185 per night" & @CRLF & _
"$400pw incl. power" & @CRLF & _
"$500 weekly" & @CRLF & _
"$600 per week pw" & @CRLF & _
"$850 per week (Fully furnished)" & @CRLF & _
"FROM $400PW, FURNITURE AND BILLS INCLUDED" & @CRLF & _
"THE DEAL- $780 PER WEEK" & @CRLF & _
"THE DEAL: $1,400 PER WEEK" & @CRLF & _
"$750/W Unfurnished" & @CRLF & _
"$320 - fully furnished pw" & @CRLF & _
"$330 PER WEEK | $1,430 P.C.M" & @CRLF & _
"Enquire Now: $690 per week" & @CRLF & _
"$460 per week / $1999 per month" & @CRLF & _
"$490 per week/Under Application approved" & @CRLF & _
"$1550pw - Location! Rare gem!" & @CRLF & _
"295 per week" & @CRLF & _
"unit 2 - $780pw unit 3 - $760pw" & @CRLF & _
"$2500 pw high, $1600pw low,$380 pn" & @CRLF & _
"from $786 - $1572 per week" & @CRLF & _
"$590 to $639" & @CRLF & _
"$280 - $290 pw"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")