$re = '/("[^"]*"|exp\h*\([^)]*\))|\h*\+\h*/m';
$str = '"ABC+DF" + someVar + exp(A+B)';
$subst = "$1\0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;