import re
regex = re.compile(r"(?:[\.\d]+\,[\.\d]+\s*?){5,5}")
test_str = ("<path d=\"M 15.43,29.45 C 23.73,28.89 38,25.96 44.2,25.42 46.48,25.22 47.41,27 47.16,29.29 46.59,34.67 45.5,46 44.14,53.63\"/>\n"
"<path d=\"M 16.91,41.07 C 19.61,40.8 36.25,38.5 45.64,37.7\"/>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")