package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)://[^/]+`)
var str = `http://www.this_is_my_perfect_url.com/blah_blah/blah_blah?=trololo
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}