#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "href="(http.+appl(?:y|ica).*?)""
Local $sString = "<div>" & @CRLF & _
" <p>Erste Fragen beantwortet Ihnen gerne Elcin Rabatli-Klappenberger" & @CRLF & _
" unter <a href="tel:+49/839868144"><span" & @CRLF & _
" class="brand-color text-bold">0891/898568144</span></a>.</p>" & @CRLF & _
" <p>Bewerben können Sie sich einfach mit Ihrem Lebenslauf über unsere" & @CRLF & _
"<a href="https://www.pisegxel.de/java-spring-jee-softwareentwickler-architekt-muenchen"" & @CRLF & _
" target="_blank">" & @CRLF & _
"" & @CRLF & _
"<p>Informationen über uns und zum Bewerbungsablauf" & @CRLF & _
"finden Sie unter <a href="https://www.isg.com/jobs/applications/applyForJobEntry.jsf?inseratnummer=83115&refererId=37" target="_blank"><span" & @CRLF & _
" class="brand-color text-bold">www.pisegxel.de</span></a></p>" & @CRLF & _
" <span" & @CRLF & _
" class="brand-color text-bold">>>> 1-Klick" & @CRLF & _
" Bewerbung</span></a> oder per Email über <a" & @CRLF & _
" href="mailto:jobs@pisdgexel.de"><span" & @CRLF & _
" class="brand-color text-bold">jobs@pissegxel.de</span></a></p>" & @CRLF & _
" " & @CRLF & _
" <p><span class="brand-color text-bold">Informationen zum Ablauf in" & @CRLF & _
" Bezug auf COVID 19:" & @CRLF & _
" </span><br />" & @CRLF & _
"<a href="https://www.pisegxel.de/application/java-spring-jee-softwareentwickler-architekt-muenchen"" & @CRLF & _
" target="_blank"> " & @CRLF & _
" Vorstellungsgespräche können via Videokon­fe­renz" & @CRLF & _
" geführt werden. Alternativ" & @CRLF & _
" ist bei Präsenzterminen die Einhaltung der Hygienevorschriften gewährleistet.<br />" & @CRLF & _
"<a href="https://www.pisegxel.de/apply/form?job=333&test=2"" & @CRLF & _
" target="_blank">" & @CRLF & _
" <strong><em>Wir freuen uns auf Ihre Bewerbung!</em></strong>" & @CRLF & _
" </p>" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")