re = /(([0-9]{4})-([0-9]{2})-([0-9]{2}))|(([0-9]{4})\/([0-9]{2})\/([0-9]{2}))/m
str = '2019/12/13
2019-12-13
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end