// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(card?|van|truck)\s?(insurance|repair|reimb|reimbursement|rental|accident|hire|tax|park(ed)?|finance)").unwrap();
let string = "1 Month Car Insurance Learner
1 Month Car Insurance Ontario
2 Car Insurance Policies No Cl
2017 Indianapolis 500 Live
2017 indy 500
2017fastlanekg
2017indy500
2017NBAFINALS
2017nfldraft
2017nhlwinterclassic
2017oscarsw
2017themasters
205ufcfightcard
214ufc
89thacademyawards
Aaa Car Repair Insurance
Aaa Insurance Rental Car Reimb
AcademyAwards2017
academyawards2017
Adfaeqfe
Advantage Grand Canyon
agarwaltaxi
Agen Judi Bola Sbobet Online
Alabama vs Clemson
Alabama vs Florida
Alabama vs Florida Live
alabamagame
Alabamavs Ole Miss
alabamavsclemson
alabamavsclemsonnet
ALAT PEMBESAR PENIS
allstarweekend2017
Allstate Car Insurance Claim A
Alvarez vs Chavez
America's CUP
americascup
americascupv
amgentourofcalifornia
angelina.J
anjelnajoli
arihanttaxi11
Army vs Navy Game
Asset Protection Car Insurance
At madrid vs Barcelona
atlantafalcons
ATTATIST LDI..AGN
ausopen
ausopn
austjnopen2018
Australian Grand Prix
Australian Open 2017
australianopen2017
Average Car Insurance Rates Ca
Average Full Coverage Car Insu
Average Price Car Insurance Te
Awards Emmy
awardstonym
BAFTA
baftaawards
Bajaj Allianz Car Insurance Ba
Bajaj Allianz Car Insurance Re
Bank Of America Cash Rewards S
Bank Of America Visa Car Renta
Barcelona vs Real Madrid
baseballm
Baywatch Movie
bearsvsbuccaneers
belmntstakes
belmonstakes
Belmont Stakes
Belmont Stakes2017
belmontstakes2017s
belmontstakess
bengalsravens
bertovsporter
Best Car Insurance Companies G
Best Car Insurance For Student
Best Car Insurance Rates In Ma
Bharti Axa Car Insurance Statu
billboardmusica
billsvspanthers
Bingo
blalbiotech
bledisloecups
bledisloecupt
BMWOpen
Bodily Injury Liability Car In
bongrilabrue
borussia dortmund vs monaco
Bracket NCAA
bracketfinalfour
Breeders Cup 2017
Brit Awards
British Gold Open2017
British Open
british Open
British Open 2017
britishopeni
britishopenn
britishopenthee
Brook vs Spence Live
brookvsspence
Caa Mastercard Insurance Renta
California Casualty Car Insura
campingworld500s
canadavsusa
canelo
Canelo fight
Canelo Fight Live
canelo gggfight
Canelo vs Chavez
Canelo vs Chavez Jr
Canelo vs Chavez Live
Canelo vs GGG
Canelo vs Golovkin
canelofightlive
Canelovs ChavezJr
canelovschavzjr
canelovschvezJr
canelovsgolo11
canelovsgolovkins
canilovsggg
Car Accident Police Report Ins
Car Hire Excess Insurance Uk R
Car Hire Excess Waiver Insuran
Car Insurance Cheap Internatio
Car Insurance Claim Denied
Car Insurance Companies In Cle
Car Insurance Deductible On Fe
Car Insurance Depreciation Cal
Car Insurance Estimate Calcula
Car Insurance Excess Protectio
Car Insurance Limits 100 300 B
Car Insurance North Carolina Q
Car Insurance Parking Definiti
Car Insurance Policy Pdf Viewe
Car Insurance Property Damage
Car Insurance Quotes Online Nj
Car Insurance Quotes Online Pr
Car Insurance Rates By Age Uk
Car Insurance Rates California
Cardinals vs Lions
Cardinals vs Seahawks Live
cardinalsvscowboys
Cavs vs Warriors
cavsvswarriorsm
Cegglers
Celtics vs Cavaliers Live
CFP Championship 2017 live
CFP Championship Game 2018
cfpchampionshiplive2018
cfplivechampionship
cfpnationalchampionship2017
cfpncg
cfpsemifinal2018
Champions League
Champions League Final
championshipnfc
championsleafil
Chargers Vs Riders
Chase Southwest Card Rental Ca
chavez vs canelo
Cheap Car Insurance Compare Qu
Cheap Car Insurance San Antoni
Cheap Car Insurance State Mini
Cheap Car Insurance Tampa Flor
Cheap Comprehensive Car Insura
Cheap Online Quotes Car Insura
Cheap Rental Car Insurance Usa
Cheaper Car Insurance For Youn
Cheapest Car Insurance Compani
Cheapest Car Insurance For Tee
Cheapest Car Insurance Massach
Check Car Insurance Ncd Malays
Chelsea vs Arsenal
cheltenham
Cimb Insurance Car
Citi Platinum Mastercard Car R
Classic Sports Car Hire Uk Ins
Clemson Football
Clemson vs Alabama
Clemson vs Alabama Live
Clemson vs Virginia Tech
clemsonfootball
ClemsonvsVirginialive
Coachella
College World Series
collegefootballlive
collegeworldd
Company Car Tax Calculator Uk
Compare Car Insurance Australi
confederationscup
conormcgregorvsfloydmayweather
Consumer Reports Cars 2011 Rat
Contestwingo
Couple Of Hours Car Insurance
Cowboys vs Cardinals live
cowboys17
cowboysdallas
cowboysnflgame
cowboysnflgg
cracksTaking1
crackstools
Cracktaking
cracktaking
Crawford vs Diaz
Crawford vs Indongo
Crawford vs Molina
crawfordvsdiaz
CrossFit Games
Davis vs Walsh
Davis vs Walsh Live Stream
davisvswalsh
Daytona 500
Daytona 500 2017 Live Stream F
Daytona 500 Live
Daytona 500 Live Stream Online
Daytona 500 streaming
daytona-500live
Delhi Repairs
derbykentuc
diabetesloophole
Does Full Coverage Car Insuran
Does Progressive Cover Rental
Dollar A Day Car Insurance New
Dolphins vs Cardinal Live
Dolphins vs. Ravens
dolphinsvscha
dongrilabrue
draft nfl
draftnba
DUKE Vs NORTH CAROLINA
Eagles Game
eaglesvsfalcons
Eduinfo
EL Clasico
El Clasico
El Clasico
EL Clasico 2017
El Macho
elclasicoc
elclasicolivex
Elimination Chamber 2017
Emmy Awards
englandvscotlandhhh
Enterprise Rent A Car Insuranc
ernestobowers
FA Cup Final
Falcons vs Packers
falconspackers
FalconsvPackersLive
falconsvspatriotsliveu
Fast and Furious 8
fastandfuriousl
Fastlane 2017
Fear the Walking Dead
Final Four
Final Four 2017
Final Four Bracket
First Direct Car Insurance Dis
Flat Belly Overnight Review
flatbellyovernight
florida17
floydmaheor
fourfinal
Frampton vs Santa Cruz
Frampton vs Santa Cruz 2 Live
Free Online Car Insurance Quot
French Open
French open
french open 2017
French Open 2017 Live
frenchop
frenchopen2017t
frozenfourxx
Galaxy Vol 2
Game of thrones
Game of thrones season 7 E4
gameofthonss7e5
gameofthronesseason7
Geico Car Insurance Bronx Ny
gennadygvsDJ
Georgia Football
georgiafootball
georginanorton
GGG v Jacobs
ggg vs jacobs
gggvscaneloj
gggvsjacobsli
gggvsjacobss
gianstsvscowboystv
Giants vs Packers
Gio Car Insurance Quote Online
giroditalia
giroditalia2017
Golden Globes 2018
goldenglobeawards2018
goldenglobes2017
golovkin jacobs
golovkin vs canelo
GolovKin vs Jacobs
Golovkin vs Jacobs
golovkinvscanelolive
golovkinvsjacob
golovkinvsjacobslive
Golvkin vs Jacobs
Grammy Award 2017
Grammy Awards 2017
Grammy Awards 2017 Live
Grammy Awards 2018
Grammys 2017
Grammys 2018
grammys2017
grammysi
Gramnys
greenbaypackers
GreenBayPackersGame
Grey Cup 2016
greycup
guardians of the galaxy vol 2
Hail Damage Claim Car Insuranc
halloffame
happynewyear
Harhoahfa
hd live watch
Heacock Classic Car Insurance
HERBAL USA ONLINE
Hit A Parked Car Insurance
horjilabrue
IAAF World Championships
Ibuyeco Car Insurance Review
India VS Pakistan
Indianapolis Live
Indy 500
indy 500 free
Indy 500 Live Stream
indy500
indy500online
Indycar 500
indycar500indycar
Indycar500live
indycaree
Instant Car Insurance Quote Es
Insurance Auto Car Rates Avera
Insurance Group 1 Cars Old Mod
Insurance Included Car Finance
Insurance Quotes For Non Car O
International Champions Cup
Intilight
iphone8
IPL 2017
Ireland vs England
Ireland vs Wales
Is Insurance More Expensive Fo
Is Van Insurance Cheaper Than
Italian Open
Italy vs France
Jaguars vs Ravens live
Jaguars vs Ravens live
jaguars17
jaintaxi
jets vs bills
johnljmart johnljmart
Joshua VS Klitschko
Joshua vs Klitschko Live
joshuafight
joshuavsKlitschko
joshuavstak
JosvKlitkolive
Kalabox
Kentucky Derby
Kentucky Derby 2017
kentucky derby 2017
Kentucky Oaks
kentuckyderbe
kentuckyderbii
kentuckyderby007
kentuckyderby2017
kentuckyderbya
kentuckyderbyhd
kentuckyderbyli
KentuckyDerbymms
kentuckyderbyxx
Kickoff2017
KidMoto
klitschkovsjJoshualive
kobalttv
Korstog
kuhegafub
LeanBellyBreakthrough
Learners Car Insurance Uk Quot
Lease Car Insurance Registered
Liberty Mutual Car Insurance Q
linaresvcrolla
Lions vs Seahawks
List Of All Car Insurance Comp
Live Stream Tv
Live Streams
liveonline
liverpoolvsche
livestreamonline
livestreams football
livestreamvs-4ktv
livestreamwatchhdtv
livevsstreamhd
Low Car Insurance In Kansas Ci
Low Rate Car Insurance Toronto
madnessmarchs
Madrid Open
March Madnes
March Madness
march madness
March Madness 2017
marchmadnes2017
marchmadness 2017
marchmadness2017o
marchmadnessli
marchmadnessvc
marchmadnessx
marchmadnessxc
Mastercard Rental Car Insuranc
Masters 2017
masters 2017
Masters Golf
masters live
mastersgolf
mastersl
masterslivex
mayweathed
Mayweather Boxing
Mayweather Jr vs Mcgregor
Mayweather Mcgregor
Mayweather vs McGregor
Mayweather vs Mcgregor
Mayweather vs McGregor Live
mayweather1277
mayweatheri
mayweatherjrvmcgregor
mayweatherjrvsm
mayweatherjrvsmc
mayweathervsmcgregor
mazerunnerc
Mcgregor
McGregor Fight
McGregor vs Alvarez
Mcgregor vs Mayweather
mcgregormayweath
mcgregorvsmayweather
mcgregorvsmayweathertv
melbournecupp
melbournsecup
Meloche Monnex Car Insurance W
MensBasketballChampionship
Mileage Based Car Insurance
Minimum Coverage Car Insurance
Minimum Required Car Insurance
Miss Universe 2017
Miss USA
Miss World
MISS-UNIVERSE
Miss-World-2017
Missed Insurance Payment Car
MissUniverse2017ca
missusa
MLB All Star Game
MLB Opening Day
MLB Playoffs
MLB World Series
mlbopeningdayx
mnffootball
mondaynightfootball1
moviesfree365
mtvmovietv
mtvtvawards17
Multi Car Insurance Geico Cont
mummymovie
Nascar Daytona
nascardaytona500
NascarDaytona500Live
nationalchampionship
NBA All Star
NBA All Star Game
NBA All Star Game 2017 live
NBA Awards 2017
NBA Finals
nba finals
NBA FINALS 2017
NBA Finals 2017
nba finals 2017
NBA Finals 2017 Live
NBA Live TV
NBA Playoff
NBA Playoffs
nba2017finals
nba2017live
nbadraftt
nbafinalspw
nbafinalss
nbaplayoffstv
nbaplayofss
nbasummerleaguem
NCAA Basketball
NCAA Bracket 2017
NCAA Championship
NCAA Tournament
NCAA Tournament 2017
NCAA Tournament Bracket
ncaahockey
ncaatournamentcx
ncaawrestling
NCC Bracket
nebraska17
New Car Insurance Company In P
New Driver Car Insurance Nj Ma
newenglandpatriots
Newyear 2017
nfcchampionshipgame
NFL 2017
NFL Draft
NFL Live Online
NFL Playoffs
NFL Playoffs 2018
nfldraft2017
nflliveonline
NFLLIVESTREAM
nflonlinenews
nflsportnews
nflstream
nflstreamfree
nflstreamingfree
nflstreams
nfltvonline
nflweek13tv
NHL Draft
NHL Playoffs
NHL playoffs
NHL playoffs 2017
nhl playoffs 2017
NHLStadiumSeries
nhlwatch01
Nilead web design company
Nit Tournament
ohiostateclemsonnet
ohiostatee
Oklahoma State vs Oklahoma
oklahoma17
Old School New Body
onepageonerank
Online Car Insurance Quotes Al
Online Quotes For Car Insuranc
Ontario Insurance Classic Car
openbritish
openf
openus
orbital2016
oregonvsnc
Oscar 2017 Live Stream
oscar 2017 live stream
Oscar Awards 2017 Live
Oscar Awards 2017 Live
Oscar2017live
oscar2017us
oscarawards2017live
oscarawardss
Oscars
Oscars 2017
oscars 2017
Oscars Awards 2017
Oscars Awards 2017 Live
Oscars2017
oscars2017c
Oscars2017Live
Oscarsbd01
oscarslivestream
osuvsvth
Packers vs Cowboys
Packers vs Cowboys Live
Packers vs Falcons
Packers vs Falcons Live
packers17
packerscowboys
packersvs17
Pacquiao vs Vargas
paddington2fullmovie
parismasters
ParkervCojanu
Patriots vs Falcons
Patriots vs Saints
Patriots vs Steelers
PatriotsLive1
patriotssteelers
patriotsvssteelershd
Payback 2017
pegasusworldcup
pennstatefootball
Peoples Choice Car Insurance U
Peter James Car Insurance
PGA Championship
pgachampionshie
pgachampionship
pgachampionshipb
pgachampionshipc
PGAChampionshipLive
pgachampionshipthe
pgachampioo
pgatour
Phillies vs Los angeles
pirates caribbean
piratesofthecaribbean5
Players Championship
playerschampionship
playerschampon
Plpd Car Insurance In Saginaw
portervsberto
Preakness
preakness
Preakness Stakes
Preakness Stakes 2017
preakness2k17
preaknessgg
preaknessstakes
Presidents Cup
Presidentscu
Pro Bowl
Pro Bowl 2018
probowl
probowl2017
pstakes
Quick Car Insurance Estimate
Quotes On Car Insurance In Lou
Raiders vs Broncos Live
Raiders vs Chiefs Live
Raiders vs Texans
raiders17
Rams vs 49ers
Ravens vs Patriots Live
RavensvsBengals
Real Madrid vs Juventus
RealMadridvsAtleticoMadridlive
Redskins
Rental Car Insurance Coverage
riyaislam
RmLaaigog
RomeMasters
rose-bowl
rosebowl2018
rosebowllive2017
Rugby League World Cup 2017
Rugby Live Stream
rugbysports
rugbyworldcupp
Russian Anchor
saint2017
saints17
sanfrancisco49ers
Sausages Wrapped In Bacon Sain
Selling Car Insurance Tips
seriesworld
Sexy ladies
Shop For Car Insurance Rates I
Six Nations
Six Nations Rugby
sixnationsk
sixnationss
sixnationsy
Sky Glue
SLbhZbqf13
songrilabrue
Sony Ericsson
spiderman0114
spidermanfilm
spidermanhomecoming
Spirit Awards
Sports Live Stream
SSC Results 2017 Bangladesh
StackOverFlow India1
Stanley Cup Finals
stanleycupfina
State Farm Average Car Insuran
State of Origin
State of Origin 2017
State of Origin 2017 Live
stateoforiginl
stateoforiginm
Steelers vs Browns
Steelers vs Patriots
Steelers vs Patriots Live
Steelers17
Stream
stream sun bigo live
Student Car Insurance Cheap
Studymedico
sugarbowl2018
sugarbowllive2017
SUPER BOWL
Super Bowl
Super Bowl 2017
Super Bowl 2017 Live
Super Bowl 2017 Live Stream
Super Bowl 2018
Super Bowl LI
Super Bowl Li
Super Rugby
Super Rygby
superrugbyfinal
superrugbylive
Supply Expert
Tafhasofhof
Tampa Tax Attorney
tells good stories
Tesco Bank Car Insurance Uk Em
Tesco Car Insurance Renewal Of
texansvbengals
Texas Open
The 2017 NBA Finals
The Academy Awards 2017 Live
The British Open
The Fate of the Furious
The Honda Classic 2017 Live
The Kentucky Derby
The Masters
The Masters 2017
The Masters 2017 Live
The Mummy
The Mummy Movie
The Players Championship
The Preakness
thebreederscup
thebritishopenn
thebritishopenw
thechampionshippga
thefrenchopen
thegrammy
themaste
themasters
themummy
theoscarawards
thepgachampionshipss
thepgachampp
thepgchampionsh
thepost2017
thepreaknes
theusopengolff
theusopenw
theworldseries
Third Party Car Insurance Sout
Third Party Insurance Cost For
thursdaynightfb
thursdaynigtfotbl
Time Limit For Reporting A Car
Tips On How To Save Money On C
Toko Jual Kondom Online
Tony Awards
Tour de France
tourofcaliforna
Trail Blazers vs Warriors Live
Transformers The Last Knight
Trends Setter
TV NBA Finals 2017
UFC 205
UFC 205 Live
UFC 205 live
UFC 206
UFC 207
UFC 207 Live
UFC 207 Live Stream
UFC 208
UFC 208 Live
UFC 209
UFC 209 live
UFC 209x
UFC 210
UFC 210 Live
UFC 211
UFC 211 Live
ufc 211 live
UFC 212
ufc 212 live
UFC 212 Live Stream
UFC 213
UFC 213 Live Stream
UFC 214
UFC 219 Live
ufc205
ufc205fightcard
UFC205live
ufc205mma
ufc206live
ufc207i.net
ufc207m
ufc208
ufc208live
ufc208s
ufc209
ufc209 fightcard
ufc209pp
ufc209ppv
ufc209sa
Ufc210 Livs2017
UFC210Fight
ufc210liveco
ufc210livestream
ufc210livetv
ufc210m13
ufc211
ufc211livefree
ufc212a
UFC214
ufc2177
ufc219i
ufcfightlive
ufclive217
ufclivetvp
ufcpp
ufctv211
ufcxx
uhfckjvfc
Uk Car Hire Excess Insurance C
universemisslive
US Open
US Open 2017
US Open 2017 Golf
US Open Golf
US Open Golf 2017
us open golf 2017 live
Us Open Tennis
us Open Tennis
Us Open Tennis 2017
US Opengolf
USA vs Mexico
usavsjamaica
uscvsstanford
usgolfopentv
usope
usopen2017golf
usopen2017online
usopenggolf
usopengolf
usopenn
usopenni
usopentennisp
ustvonline
us_open
uwikipedia
Valentines Day Images
Valero Texas Open
Wales vs Ireland
Ward Kovalev
Ward vs Kovalev
wardkovalev
wardvskovalevi
warriorsvjazz
watchdaytona500online
watchnflonline
watchufc205
wbcxx
Western Kentucky vs Louisiana
wgcmexicochampi
What States Have High Car Insu
Wheatley
Windsor Ontario Car Insurance
Winter X Games 2018
winterClassic2017
Wisconsin vs Penn State
wisconsinn
womanwonder
womensrugbyworldcuplive
Wonder Woman
wonderwoman2017
World Baseball Classic 2017
World Junior 2017
World Series
World Series 2017
worldserh
worldseries
worldseriescollege
worldseriesgame
Worldwide Travel Insurance Car
WrestleMania
wrestlemania
WrestleMania 33
wrestlemania 33
WrestleMania 33 Live
Wrestlemania 33 Live
WrestleMania33
wrestleMania33
wrestlemania33
wrestlemania33live
wrestlemania33live04
wrestleManiapi
wrestlemaniax
wrestlemaniaxde
wstonvsbtn
WWE Royal Rumble 2017
WWE WrestleMania 33 live
wwewrestlemania33
wwewrestleManip
Xfinity Car Insurance Pa
Young Drivers Cheap Car Insura
Zurich Classic";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}