package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)((?:(?:[a-zA-Z0-9-]+\.)?[a-zA-Z]+\.)?(google)\.com)`)
var str = `test@google.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}