using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.* SYSB ).* Activated\b";
string input = @" 1 ID_1 INSV enabled Activated 12.345.67.89
2 ID_2 SYSB Disabled Activated 12.345.67.89
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}