package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:, so|(\bso))\b`)
var str = `So that
so big that
, so so`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}