re = /\G(?:(?:^|;)\s*)(?|"([^"]*)"|([^;]*?))(?:\s*(?:(?=;)|$))/
str = '"0;0";1;2;3;4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end