$re = '~\(\s*(\S+)\s*\)~m';
$str = 'I\'m trying to get the file name between two parentheses that can contain spaces between the name and any parentheses. example: ( file_name )';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);