re = /^(?=.*\d)(?=.*[A-Z])(?=.*[a-z])(?=.*[^\w\d\s:])([^\s]){8,16}$/m
str = '/^(?=.*\\d)(?=.*[A-Z])(?=.*[a-z])(?=.*[^\\w\\d\\s:])([^\\s]){8,16}$/gm
_}24I:9t58Tu?m@e
|YlzEc|1
#m_4xF%t"Bu5jeb$
Password1!
12345678aA
^@},^@},^@},
12345678aA@
12345678 aA@
12345678aA@
AbCdEfGhIi
abcdefgh123
ABCDEFGH1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end