$re = '/^(101)\d{3,}$|^\*xy(101|011)\d{6,}$/m';
$str = '101122
*xy101121111
*xy011123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);