re = /\b\d+\b\D*/m
str = '1964 ORDINARY shares
EXECUTORS OF JOANNA C RICHARDSON
100 ORDINARY shares
TG MARTIN
C MARTIN
7500 ORDINARY shares
ARCO LIMITED'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end