import re
regex = re.compile(r"\$(\{(?P<braced_cmd_var>[a-zA-Z0-9_]+)\}|(?P<cmd_var>[a-zA-Z0-9_]+))", flags=re.MULTILINE)
test_str = "pcasl_cbf_adapter --grase-kgn --verbose --subject-id=$SUBJECT_ID --session-id=${SESSION_ID} \"$IN_DIR\" \"${OUT_URI}\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")