const regex = /\s*[,-]?\s*[[(]?part[\s-:]\w+#?[\])]?/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*[,-]?\\s*[[(]?part[\\s-:]\\w+#?[\\])]?', 'ig')
const str = ` - The revenge of the wolf Part 2.
- Along the road, part III.
- Somewhere over the rainbow (part one)
- etc [part 4#]
- In the cloud - [part 1]
- In the cloud - [part 2] the destiny
- In the cloud, [part 3]
- In the cloud, [part 4] the final
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}