$re = '/(?<="memberNumber" : {\n "string" : "[0-9]{3})[A-Z]{2}/m';
$str = ' "eventData" : {
"header" : {
"correlationId" : "d1ae2af3-1b2d-41dc-afe7-1f61c5e3a2d8",
"memberNumber" : {
"string" : "636FP25979"
},
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);