package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im).+@.+\..+`)
var str = `sdf@asdfsdfasd.ru
sdf@asdfasd.ru
@@@@@@.@@`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}