$re = '/0000..00............00....00/ms';
$str = 'grid is
11000110000010111
00000100000110001
10010000100010000
10101000110100100
shape is
0000..00
..00....00
flattened shape
0000..00............00....00
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);