const regex = /id : (?:[A-Za-z]+:)?\/{0,3}([0-9.\-A-Za-z]+)(?::(\d+))?(?:\/([^?#]*))?(?:\?([^#]*))?(?:#(.*))?, OS : ([\w]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('id : (?:[A-Za-z]+:)?\\\/{0,3}([0-9.\\-A-Za-z]+)(?::(\\d+))?(?:\\\/([^?#]*))?(?:\\?([^#]*))?(?:#(.*))?, OS : ([\\w]+)', 'gm')
const str = `id : http://17.196.32.47:5555, OS : MAC`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}