$re = '/\b([a-zA-Z]\w*)(?:[^(a-zA-Z0-9_]|$)/';
$str = ' a*sin(w*t)
a+b/c
w3_so^2+y^2/2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);