import re
regex = re.compile(r"((?<!t\. | § |tz |h. )\b[0-9][a-z]?\b(?!A))", flags=re.MULTILINE)
test_str = ("Art. 19 Cst.\n"
"§ 39 VG\n"
"§ 39 Abs. 1 und 2 VG\n"
"Art. 19 BV\n"
"Art. 62 Abs. 1 BV\n"
"Art. 3 BV\n"
"Art. 62 Abs. 2 BV\n"
"Art. 19 und 62 BV\n"
"Art. 13 UNO-Pakt I\n"
"Art. 28 KRK\n"
"Art. 19 BV\n"
"Art. 62 BV\n"
"Art. 62 BV\n"
"Art. 62 BV\n"
"Art. 62 BV\n"
"Art. 27 BV\n"
"Art. 14 KV/ZH\n"
"Art. 19 BV\n"
"Art. 19 BV\n"
"Art. 116 KV/ZH\n"
"Art. 27 BV\n"
"Art. 62 BV\n"
"Art. 62 BV\n"
"Art. 62 BV\n"
"Art. 62 BV\n"
"Art. 19 BV\n"
"Art. 36 BV\n"
"§ 39 Abs. 1 VG\n"
"§ 39a Abs. 1 VG\n"
"§ 39 Abs. 1a VG\n"
"§ 39 Abs. 1 VG\n"
"§ 39 VG\n"
"§ 39 Abs. 2 VG\n"
"Art. 302 Abs. 1 ZGB\n"
"§ 39 Abs. 2 Satz 1 VG\n"
"Art. 19 BV\n"
"Art. 8 Abs. 1 und 2 BV\n"
"Art. 19 und Art. 62 Abs. 2 BV\n"
"§ 39 Abs. 1 und 2 VG\n"
"Art. 18 BV\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")