package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b`)
var str = `Rogue One: A Star Wars Story`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}