$re = '/([a-zA-Z0-9]+)\.([a-zA-Z0-9]{1,3})?/m';
$str = 'hotmail.
living.
item.
2.
4S.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);