package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[-+]?\b\d+(?:\.\d+)?\b`)
var str = `123 -111.9 ww1 111 q2q2 1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}