import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(\\*\\*Bewerbung von .*:\\*\\*\\n\\n\\*Name:\\* .*\\n\\*MC-Name:\\* .*\\n\\*Alter:\\* .*\\n\\*Aufgabe:\\* .*\\n\\*Vorteile:\\* .*\\n\\*Gründe:\\* .*)|(.+))$";
final String string = "Change Regex to negative\n\n"
+ "Need help with a regex. I have a discord server where I use Sapphire (a discord bot) for applications. The normal regex for the normal application works, just not the one where it should check for messages that do NOT fit the template.\n"
+ "Here's the normal one (that works):\n\n"
+ "**Bewerbung von :**\n\n"
+ "*Name:* \n"
+ "*MC-Name:* \n"
+ "*Alter:* \n"
+ "*Aufgabe:* \n"
+ "*Vorteile:* \n"
+ "*Gründe:* \n\n"
+ "And here the other that doesn't work and that should check for message that don't fit the template:\n\n"
+ "```^(?!.*(?:Bewerbung von|Name:|MC-Name:|Alter:|Aufgabe:|Vorteile:|Gründe:)).*$```\n\n"
+ "Can someone help me? I just want the secon regex to check for messages that do not contain these words (\"Bewerbung von\", \"Name:\", etc.)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}