package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w][0-9]+$`)
var str = `3434
02
qwq3434
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}