$re = '~[a-z]+|(?:\d+(?:\.\d+)?)|[-+/*=]~';
$str = '12.3+22-this*4/varable
1+a=3-b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);