package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\"id\":\"(?<id>[^\"]+)`)
var str = `{"line":"c5fd03529388e8d6 INFO 2021-06-10 04:11:02,966 [reactor-http-epoll-2] com.test.content.test.external.SnsPayloadEventSender Sent payload event id=9a67e81d-5ae3-5e84-b1f7-b126c9f5c787 for payload event={"approvalDate":"2015-06-10T04:11:02.128Z","adenceIds":[],"adenceTargets":[],"collGroupId":"008be467-6c78-4079-94f0-70e2d6cc4003","collections":["d879aa85-698c-41a1-b066-a8ecdf6b8a9c","d879aa85-698c-41a1-b066-a8ecdf6b8a9c"],"endSchedule":"3000-01-01T19:00:00.000Z","id":"0827ce61-e07c-4b51-a052-681dcc94fa2f","language":"ja","mplace":"JP","nodeVersion":null,"payloadType":"thread","preview":false,"resourceSubType":"thread","resourceType":"thread","startSchedule":"2021-03-26T22:00:28.000Z","type":"P","version":"1622644250765"}","source":"stdout","tag":"21c5897e605c","attrs":{"application":"test","team":"test"}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}