$re = '/(?<=[a-zA-ZÀ-ž])\.+ *(?=[^.,])/m';
$str = 'č.1 > match č.1
St.M
2.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);