re = /(([0-9]{1,2}|[a-z]{1,3})-([0-9]{2,3}|[a-z]{2,3})-([0-9]{1,2}|[a-z]{1,2})){8}/i
str = 'XX-99-99XX-99-99XX-99-99XX-99-99XX-99-99XX-99-99XX-99-99XX-99-99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end