re = /(?<=perro)/m
str = 'El perro de san roque no tiene rabo porqué Ramon Rodríguez se lo ha robado.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end