# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^
# Possible: http://
# https://
# //
(?:(?:https?:)?//)?
# Possible: www.
# m.
(?:(?:www|m)\.)?
# Possible: youtube.com
# youtube-nocookie.com
# youtu.be
(?:(?:youtube(?:-nocookie)?\.com|youtu.be))?
# Possible: /[a-zA-Z0-9_-]+?v=
# /embed/
# /v/
(?:/(?:[\w-]+\?v=|embed/|v/)?)?
# Possible: oembed?url=...v=
(?:oembed\?url=.*\?v%3D)?
# TOKEN: [a-zA-Z0-9_-]
([\w-]{11})
# Possible: Anything not space+
(?:\S+)?
# EOF pattern with x(PCRE_EXTENDED) flag:
$
"""
test_str = ("Matches:\n"
"DFYRQ_zQ-gk\n"
"https://www.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"https://www.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"youtube.com/watch?v=DFYRQ_zQ-gk\n"
"https://www.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"https://www.youtube.com/v/DFYRQ_zQ-gk?version=3&autohide=1\n"
"https://youtu.be/DFYRQ_zQ-gk\n\n"
"https://www.youtube.com/watch?v=DFYRQ_zQ-gk&feature=featured\n"
"https://www.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"http://www.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"//www.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"www.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"https://youtube.com/watch?v=DFYRQ_zQ-gk\n"
"http://youtube.com/watch?v=DFYRQ_zQ-gk\n"
"//youtube.com/watch?v=DFYRQ_zQ-gk\n"
"youtube.com/watch?v=DFYRQ_zQ-gk\n\n"
"https://m.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"http://m.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"//m.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"m.youtube.com/watch?v=DFYRQ_zQ-gk\n\n"
"https://www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US\n"
"http://www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US\n"
"//www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US\n"
"www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US\n"
"youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US\n\n"
"https://www.youtube.com/embed/DFYRQ_zQ-gk?autoplay=1\n"
"https://www.youtube.com/embed/DFYRQ_zQ-gk\n"
"http://www.youtube.com/embed/DFYRQ_zQ-gk\n"
"//www.youtube.com/embed/DFYRQ_zQ-gk\n"
"www.youtube.com/embed/DFYRQ_zQ-gk\n"
"https://youtube.com/embed/DFYRQ_zQ-gk\n"
"http://youtube.com/embed/DFYRQ_zQ-gk\n"
"//youtube.com/embed/DFYRQ_zQ-gk\n"
"youtube.com/embed/DFYRQ_zQ-gk\n\n"
"https://www.youtube-nocookie.com/embed/DFYRQ_zQ-gk?autoplay=1\n"
"https://www.youtube-nocookie.com/embed/DFYRQ_zQ-gk\n"
"http://www.youtube-nocookie.com/embed/DFYRQ_zQ-gk\n"
"//www.youtube-nocookie.com/embed/DFYRQ_zQ-gk\n"
"www.youtube-nocookie.com/embed/DFYRQ_zQ-gk\n"
"https://youtube-nocookie.com/embed/DFYRQ_zQ-gk\n"
"http://youtube-nocookie.com/embed/DFYRQ_zQ-gk\n"
"//youtube-nocookie.com/embed/DFYRQ_zQ-gk\n"
"youtube-nocookie.com/embed/DFYRQ_zQ-gk\n\n"
"https://youtu.be/DFYRQ_zQ-gk?t=120\n"
"https://youtu.be/DFYRQ_zQ-gk\n"
"http://youtu.be/DFYRQ_zQ-gk\n"
"//youtu.be/DFYRQ_zQ-gk\n"
"youtu.be/DFYRQ_zQ-gk\n\n"
"https://www.youtube.com/HamdiKickProduction?v=DFYRQ_zQ-gk\n"
"https://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3DDFYRQ_zQ-gk&format=json\n\n"
"No Matches:\n"
"Hello https://www.youtube.com/watch?v=nzj7Wg4DAbs world\n"
"http://youtu.be/\n"
"youtube is cool\n"
"youtube/cCnrX1w5luM\n"
"http://youtube/cCnrX1w5luM\n\n")
matches = re.finditer(regex, test_str, re.VERBOSE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.