package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+) ((optional \s*)?def)\s+(.+)`)
var str = `abc optional def ghi`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}