package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(0[0-9]|1[0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])(?:|(?:\.)([0-9]{1,6}))`)
var str = `12:00:09.123
12:00:09`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}