import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\n)(\\d{4}(?:-\\d{2}){2} (?:\\d{2}:){2})\\d{2}\\.\\d{3}( [+-]\\d{2}:\\d{2} )\\[\\d+\\]( - Starting)[^\\n]*(?:\\n\\1\\d{2}\\.\\d{3}\\2\\[\\d+\\][^\\n]*)*\\n\\1\\d{2}\\.\\d{3}\\2\\[\\d+\\]\\3[^\\n]*";
final String string = "2019-10-31 05:49:52.416 +10:00 [1] - Starting\n"
+ "2019-10-31 05:49:53.416 +10:00 [2] - not starting\n"
+ "2019-10-31 05:49:53.416 +10:00 [2] - Starting\n"
+ "2019-10-31 05:49:53.416 +10:00 [3] - Starting\n"
+ "2019-10-31 06:53:58.416 +10:00 [1] - Starting\n"
+ "2019-10-31 06:53:58.416 +10:00 [1] - Identical but not \"starting\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}