package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\-7\-\R`)
var str = `-7-
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}