package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`ALARMS:(\s(\w+))*`)
var str = `ALARMS: FIRST SECOND `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}