using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![a-zA-Z])[a-zA-Z]\K\d+";
string input = @"A12B8Y9CC10
V5C8I17
KK18II9
I8VV22ZZ4S9U2
A18Z12I";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}