re = /\b([A-Z]+(?:\s+[A-Z]+)*):\s*(.*?)(?=\s*\b(?:[A-Z]+(?:\s+[A-Z]+)*):|$)/m
str = 'INCIDENTS: Quick fox ran over. A plane drove the head. RESULT AND CONCLUSION: I got headache, and fever'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end