import re
regex = re.compile(r"(?:(?<=\s)\w+(?=\[))|(?:(?<=>)\w+(?=\[|:))", flags=re.MULTILINE)
test_str = ("<103>CP-MGMT xpand[2859]: Configuration changed from localhost by user admin by the service dbset\n"
"<31>routed[4006]: rt_instance_monitor_job: scheduled next instance monitor in 5 seconds\n"
"<134>CP_FireWall: 2Jul2017 18:52:23 accept ip address message")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")