$re = '/(?!^-)(?=[+-])/m';
$str = '5x^3-2x^2+5x
5x^3-2x^2+5x-5
-5x^3-2x^2+5x+5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);