$re = '/@design-param-value\s(.+?)\s(.+)\n/m';
$str = '/**
* @design-param-value propToBeBinded "Value"
*/
/**
* @design-param-value propToBeBinded {obj: "asdf"}
*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);