re = /(?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May?|June?|July?|Aug(?:ust)?|Sep(?:t(?:ember)?)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?\s+\d{2},\s+\d{4})/m
str = 'the date is December 15, 2009
Nov 15,1909
Jan 15,1809
January 15,2009
Dec 22, 2014'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end