$re = '/measures:\s+\{\s+(?<your_field>[^:]+)/m';
$str = 'measures: {
API.V1.WEBS_ENTITLED_PRODUCTS: 296
success: 300
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);