$re = '/(?<=my name is ).*/m';
$str = 'gey du d
my name is Arivu anbu
she ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);