$re = '/FileEventCreator - Completed Settlement file processing, (?<file>[^ ]*) records processed: (?<records_processed>\d+)/m';
$str = 'FileEventCreator - Completed Settlement file processing, TRIM.UNB.D082423.T065617 records processed: 13169530
FileEventCreator - Completed Settlement file processing, TRIM.BLD.D082423.T062015 records processed: 3388398';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);