re = /^(AB|AG|AR|B|BC|BH|BN|BR|BT|BV|BZ|CJ|CL|CS|CT|CV|DB|DJ|GJ|GL|GR|HD|HR|IF|IL|IS|MH|MM|MS|NT|OT|PH|SB|SJ|SM|SV|TL|TM|TR|VL|VN|VS)-(0[1-9]|[1-9][0-9]|[1-9][0-9][0-9])-[A-Za-z]{3}$/
str = 'B-111-ABC'
# Print the match result
str.match(re) do |match|
puts match.to_s
end