$re = '/test-[0-9-]+/m';
$str = 'test-200-12-30-2990';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);